Nasveti in napotki ter povpraševanja...
 
matejgt
Nov uporabnik
 
Prispevkov: 30
Pridružen: Sr okt 06, 2004 12:42 am

signali na senzorju

Napisal/-a matejgt Sr mar 31, 2021 2:19 pm

Pozdravljeni!
Imam C3 ki ima težavo, namreč števec kaže vedno "0" in posledično je volan trd in še ugasne velikokrat, ko stisneš sklopko! Skratka poskušal sem menjati senzor hitrosti na menjalniku, vendar zadeva še vedno ne dela! Meril sem napetosti na priključku senzorja in zadeva deluje malo čudno! Ima tri pine, sredinski je masa, če merim napetost ko dam kontakt pa je iz sredinskega (mase) proti prvem napetost 12,8V, proti tretjemu pa 11,5V! Zdej nekako sem pričakoval da bo napetost samo na enem, na drugem pa da gre signal od senzorja proti računalniku, torej bi naj bil brez napetosti, ali se morda motim? Hvala
 
Uporabniški avatar
Firediver
Mojster foruma
 
Prispevkov: 3388
Pridružen: Če dec 09, 2004 6:59 pm

Re: signali na senzorju

Napisal/-a Firediver Sr mar 31, 2021 2:34 pm

Najprej priklopi na spodoben tester, sicer utegne hitro nastati še več škode.
Glede na opisane težave bo najprej potrebno pobrisati vse napake, da se začnejo izpisovati najnovejše in na podlagi tega poiskati vzrok ali pa pot do vzroka okvare.

To, da je za nedelujoč merilnik hitrosti kriv kar senzor hitrosti, je veljalo v prejšnjih časih, ko še ni bilo računalnikov v vozilu. Sedaj pa brez testerja ne gre več.
Človek brez problema, to strašna je stvar!
 
Uporabniški avatar
Fan
Konstruktiven svetovalec
 
Prispevkov: 5980
Pridružen: So avg 16, 2008 10:36 pm
Kraj: Ljubljana

Re: signali na senzorju

Napisal/-a Fan Sr mar 31, 2021 3:47 pm

X2
Po opisu je na vozilu kar nekaj težav, ki pa žal niso povezane. Kot je bilo že priporočeno, najprej spodoben tester.
Vse je lepo, če vidijo prave oči.
 
matejgt
Nov uporabnik
 
Prispevkov: 30
Pridružen: Sr okt 06, 2004 12:42 am

Re: signali na senzorju

Napisal/-a matejgt Sr mar 31, 2021 5:34 pm

....mislim da je napaka samo ena, drugo so posledice napake! Ker ima progresivni volan, se v primeru nepravilnega delovanja (merjenja) servo volan izključi oziroma d v "safe mode" kar pomeni da ni popolnoma izključen ampak vseeno precej trd! Da avto ugasne pa tudi mislim da je posledica iste napake, kajti vse se je pričelo dogajat od istega trenutka naprej! Ja priklopil sem pač en poceni obd2 "tester" ki pa napake niti ne javi oziroma napiše brez napake!
No vseeno sem mislil če bi kdo pokomentiral te napetosti na priključku,...... Ja sej bom morda tudi na servis peljal, ampak še nevem ker je letnik 2003 in če se mehanih nekaj ur igra, bo hitro cena višja od vrednosti vozila!
 
uros11
Poznavalec foruma
 
Prispevkov: 1611
Pridružen: Če nov 08, 2007 10:52 am

Re: signali na senzorju

Napisal/-a uros11 Sr mar 31, 2021 5:47 pm

matejgt je napisal/-a:na drugem pa da gre signal od senzorja proti računalniku, torej bi naj bil brez napetosti
Kako lahko obstaja signal, ne da bi obstajala napetost .............. kaj je po tvoje signal?
 
matejgt
Nov uporabnik
 
Prispevkov: 30
Pridružen: Sr okt 06, 2004 12:42 am

Re: signali na senzorju

Napisal/-a matejgt Sr mar 31, 2021 5:59 pm

Po moje bi moralsenzor dobiti napetost torej + in - , senzor je pa tisti ki bi naj dajal nazaj (v nasprotni smeri) signal! Tko si sam predstavljam, da nekaj ne štima na napetostih na priključku senzorja, kjer je kot opisano na sredini masa, na preostalih pinih pa je napetost, na eni je "po moje" pravilna 12,8V to je napetost iz baterije, na drugem, 11,5V pa mi ne deluje pravilno, mislim da ne bi smelo tukaj biti napetosti!
 
Uporabniški avatar
Gricko
Poznavalec foruma
 
Prispevkov: 1768
Pridružen: Sr jun 02, 2004 8:49 pm
Kraj: ljubljana AR156SW

Re: signali na senzorju

Napisal/-a Gricko Sr mar 31, 2021 6:10 pm

že odgovor pred mano te sprašuje enako

kaj pa JE signal? kaj drugega kot napetost?

seveda dobiš nazaj napetost samo ta ni stalna ......
 
matejgt
Nov uporabnik
 
Prispevkov: 30
Pridružen: Sr okt 06, 2004 12:42 am

Re: signali na senzorju

Napisal/-a matejgt Sr mar 31, 2021 7:19 pm

...morda sem se slabo izrazil... torej napetosti sem meril pri odklopljenem senzorju na konektorju! Torej tam, vsekakor ne more biti signala od senzorja! In mislim da bi eden od pinov moral biti brez napetosti, kjer ob priklopu na senzor teče signal! In ja, signal je napetost, vendar ponavadi precej nižja od 12V! Ta signal (signal seveda ni stalna napetost) ne more potekat po žici, na kateri je že napetost, ali pač?
 
Uporabniški avatar
Firediver
Mojster foruma
 
Prispevkov: 3388
Pridružen: Če dec 09, 2004 6:59 pm

Re: signali na senzorju

Napisal/-a Firediver Sr mar 31, 2021 7:40 pm

Če se že greš "kavbojca" brez kakršnihkoli podatkov o senzorju...

Naredi si adapter, da lahko pri spojenem konektorju priklopiš voltmeter med maso in izhodno sponko senzorja. Potem pa moraš nekako generirati hitrost, da preveriš, če se vrednost na izhodu senzorja spreminja v ritmu te hitrosti. Ker nimaš podatka, kako senzor sploh deluje, je to največ, kar lahko narediš.
Človek brez problema, to strašna je stvar!
 
Uporabniški avatar
Gricko
Poznavalec foruma
 
Prispevkov: 1768
Pridružen: Sr jun 02, 2004 8:49 pm
Kraj: ljubljana AR156SW

Re: signali na senzorju

Napisal/-a Gricko Sr mar 31, 2021 7:47 pm

matejgt@
narobe misliš....
nismo več v časih relejev ( kjer je napetost bila ali pa je ni bilo) ampak v dobi polprevodnikov , kjer brez nekega bremena dobiš na pinu marsikaj, kar dejansko ni
signal pa je ponavadi neka predvidena vrednost v določenem območji ali pa PWM........

menjati neke senzorje kar tako je brezveze, kot so ti že povedali - TESTER in potem dalje....
 
matejgt
Nov uporabnik
 
Prispevkov: 30
Pridružen: Sr okt 06, 2004 12:42 am

Re: signali na senzorju

Napisal/-a matejgt So apr 10, 2021 8:35 pm

Evo, rešena zadeva, vsaj za enkrat! Torej napaka odpravljena! Kupil sem tester s katerim sem resetiral "bsi" in zadeva zaenkrat dela, bomo vidli koliko časa! Je pa najprej pričel delat števec, nato sem resitiral še volan "z testerjem" in nato je zadeva pričela delovat kot mora, sepravi števec dela, volan dela in avto ne ugasne več ko stisneš sklopko! Mislim da je vse stvar v "BSI" sistemu, torej podnožju varoval, ki ni samo to ampak je zadeva podobna kot računalnik!
 
Uporabniški avatar
Gricko
Poznavalec foruma
 
Prispevkov: 1768
Pridružen: Sr jun 02, 2004 8:49 pm
Kraj: ljubljana AR156SW

Re: signali na senzorju

Napisal/-a Gricko So apr 10, 2021 10:05 pm

če si samo resetiral, potem napake nisi odpravil!

sicer ni nič narobe s tem kar si naredil, samo verjetno se bo napaka ponovila ( če trenutno ni prisotna, je ok, jo je pa verjetno nekaj sprožilo- ali slab stik, ali kakšen slab senzor)

torej ko se ti ponovi, moraš iskati vzrok za to in ga odpraviti, sicer boš stalno brisal napake "do naslednjič"

je pa take napake, ki niso prisotne stalno ampak le ob določenih trenutkih zelo zamudno iskati....

preglej YT z podobnimi napakami na enakem avtu, mogoče dobiš idejo, kje iskati...

lp
 
matejgt
Nov uporabnik
 
Prispevkov: 30
Pridružen: Sr okt 06, 2004 12:42 am

Re: signali na senzorju

Napisal/-a matejgt So apr 10, 2021 10:40 pm

.....ja sej sem napisal "vsaj za enkrat"! Očitno je napako nekaj sprožilo in pač vprašanje kdaj se spet pojavi! Bomo videli kako bo, če bo potrebno vsake pol leta resitirat ni problema, če se je treba stem ukvarjat tedensko pa je je to težava, ki jo je vseakor treba odpravit!
Vrni se na Popravila in okvare na vozilih

Kdo je prisoten

Po forumu brska: Google Adsense [Bot], McLaren in 27 gostov